Citrix Workspace flaw can allow remote hack of devices running vulnerable app

Citrix addressed a vulnerability in its Citrix Workspace app that can allow an attacker to remotely hack the computer running the vulnerable application

Citrix has patched a high severity vulnerability, tracked as CVE-2020-8207, affecting its Workspace app that can be exploited by an attacker to remotely hack the computer running the flawed application.

The flaw affects the automatic update service used by the Citrix Workspace app for Windows. The vulnerability can be exploited by a local attacker to escalate privileges or by a remote attacker to execute arbitrary commands on the affected application.

The vulnerability was discovered by a researcher from Pen Test Partners. The company has published a blog post explaining how the weakness can be exploited by a local attacker to escalate privileges to SYSTEM and remotely for arbitrary command execution.

The advisory published by the vendor confirmes that the issue only impact the Windows version of the Workspace app and only exists if the application was installed using a local or domain admin account.

A remote attacker can exploit the flaw only if SMB is enabled and the affected update service is running.

“Citrix Workspace is vulnerable to a remote command execution attack running under the context of the SYSTEM account.  By sending a crafted message over a named pipe and spoofing the client process ID, the Citrix Workspace Updater Service can be tricked into executing an arbitrary process under the SYSTEM account.” reads a blog post published by researchers from Pen Test Partners that discovered the flaw. “Whilst a low privilege account is required to perform the attack, environments that do not implement SMB signing are particularly vulnerable since an attack can be achieved without knowing valid credentials through NTLM credential relaying.”

Pen Test Partners also shared video proof of concept for this vulnerability.

This vulnerability affects the following supported versions of Citrix Workspace app for Windows:

Citrix Workspace app for Windows 1912 LTSR Citrix Workspace app for Windows 2002 Citric has released versions 1912 LTSR CU1 and 2006.1 to address the vulnerability.

Earlier this month, Citrix addressed 11 vulnerabilities affecting the ADC, Gateway, and SD-WAN WANOP networking products. The vulnerabilities could be exploited by attackers for local privilege escalation, to trigger a DoS condition, to bypass authorization, to get code injection, and to launch XSS attacks.

Some of the addressed flaws could be exploited only if the attackers have access to the targeted system and request user interaction, or other conditions must be verified. For this reason, Citrix believes the flaws are less likely to be exploited.

A few days later, hackers started scanning the web for systems affected by the recently disclosed Citrix vulnerabilities.

Johannes Ullrich, the head of research at the SANS Technology Institute, confirmed that one of its honeypots set up to capture attacks attempting to exploit the recently disclosed flaw in the F5 Networks’ BIG-IP systems was targeted by hackers attempting to exploit two of the recent Citrix vulnerabilities.

window._mNHandle = window._mNHandle || {};
window._mNHandle.queue = window._mNHandle.queue || [];
medianet_versionId = “3121199”;

try {
window._mNHandle.queue.push(function () {
window._mNDetails.loadTag(“762221962”, “300×250”, “762221962”);
});
}
catch (error) {}

Pierluigi Paganini

(SecurityAffairs – hacking, Citrix Workspace)

The post Citrix Workspace flaw can allow remote hack of devices running vulnerable app appeared first on Security Affairs.